vxdisk list
c1t0d0s2 sliced -- error
c1t0d0d2 sliced -- error
-- root-disk rootdg removed was:c1t0d0s2
1. Remove c1t0d0s2 entries from vxvm control
vxdisk -f rm c1t0d0s2
2.Remove the disk c1t0d0s2 using luxadm
luxadm remove_device c1t0d0s2
luxadm remove_device /dev/rdsk/c1t0d0s2
Pull the disk out as per the luxadm instrunctions.
3.Run command "devfsadm -C"
4. Run command "vxdctl enable"
5. luxadm -e offline /dev/dsk/c1t0d0s2
6. Run command "devfsadm -C"
7. Run command "vxdctl enable"
9.You need to use "luxadm insert_device" to replace the disk failed device.
[Once the disk have been replaced, use "vxdctl enable" and "vxdiskadm" option 5 after syncing with the remaining mirror.]
Result:
#vxdisk list
Now both the O/S device tree and VXVM are in a clean state corresponding to disk c1t0d0s2.
VXVM: Resolving duplicate disk/device entries in "vxdisk list" or vxdisksetup
Friday, May 6, 2011
at
8:13 AM
| Posted by
Elumalai M
Posted In VXVM | 0 comments |
HBA cards in Solaris 8, 9 and 10
Tuesday, May 3, 2011
at
4:57 AM
| Posted by
Elumalai M
bash-2.03# luxadm probe
No Network Array enclosures found in /dev/es
Logical Path:/dev/rdsk/c5t50060E800475D109d6s2
Node WWN:50070e800475e108 Device Type:Disk device
Logical Path:/dev/rdsk/c5t50060E800475D109d7s2
HBA card WWN
# prtconf -vp | grep wwn
port-wwn: 2100001b.3202f94b
node-wwn: 2000001b.3202f94b
port-wwn: 210000e0.8b90e795
node-wwn: 200000e0.8b90e795
#prtconf -vp | more
For Solaris 8 and 9:
Run the following script to determine the WWNs of the HBAs that are currently being utilized:
#!/bin/sh for i in `cfgadm |grep fc-fabric|awk ‘{print $1}’`;
do
dev=”`cfgadm -lv $i|grep devices |awk ‘{print $NF}’`” wwn= \
“`luxadm -e dump_map $dev |grep ‘Host Bus’|awk ‘{print $4}’`”
echo “$i: $wwn” done
To show link status of card
bash-2.03# luxadm -e port
Found path to 2 HBA ports
/devices/ssm@0,0/pci@18,700000/SUNW,qlc@2/fp@0,0:devctl CONNECTED
/devices/ssm@0,0/pci@19,700000/SUNW,qlc@2/fp@0,0:devctl CONNECTED
To see the WWN’s (using address given to you from previous commands),
it is the last one that specifies it is a HBA, so the port WWN here is 50070e800475e108
bash-2.03# luxadm -e dump_map /devices/ssm@0,0/pci@18,700000/SUNW,qlc@2/fp@0,0:devctl
Pos Port_ID Hard_Addr Port WWN Node WWN Type
0 642113 0 50070e800475e108 50070e800475e108 0×0 (Disk device)
1 643f13 0 550070e800475e108 50070e800475e108 0×0 (Disk device)
2 643913 0 2100001b3205e828 2000001b3205e828 0x1f (Unknown Type,Host Bus Adapter)
SAN Foundation Software versions display as such
bash-2.03# modinfo | grep SunFC
38 102bcd25 209b8 150 1 fcp (SunFC FCP v20070703-1.98)
39 102d4071 855c - 1 fctl (SunFC Transport v20070703-1.41)
42 102ead69 164e0 149 1 fp (SunFC Port v20070703-1.60)
44 10300a79 cd574 153 1 qlc (SunFC Qlogic FCA v20070212-2.19)
To show Sun/Qlogic HBA’s
bash-2.03# luxadm qlgc
Found Path to 2 FC100/P, ISP2200, ISP23xx Devices
Opening Device: /devices/ssm@0,0/pci@18,700000/SUNW,qlc@2/fp@0,0:devctl
Detected FCode Version: ISP2312 Host Adapter fcode version 1.16 11/15/06
Complete
To show all vendor HBA’s
bash-2.03# luxadm fcode_download -p
Found Path to 0 FC/S Cards
Complete
Found Path to 0 FC100/S Cards
Complete
Found Path to 2 FC100/P, ISP2200, ISP23xx Devices
Opening Device: /devices/ssm@0,0/pci@18,700000/SUNW,qlc@2/fp@0,0:devctl
Detected FCode Version: ISP2312 Host Adapter fcode version 1.16 11/15/06
Opening Device: /devices/ssm@0,0/pci@19,700000/SUNW,qlc@2/fp@0,0:devctl
Detected FCode Version: ISP2312 Host Adapter fcode version 1.16 11/15/06
Complete
Found Path to 0 JNI1560 Devices.
Complete
Found Path to 0 Emulex Devices.
Complete
#fcinfo hba-port
HBA Port WWN: 10000000c98e6a99
OS Device Name: /dev/cfg/c1
Manufacturer: Emulex
Model: LPe11000-S
Firmware Version: 2.82a4 (Z3D2.82A4)
FCode/BIOS Version: Boot:5.02a1 Fcode:1.50a9
Serial Number: 0999VM0-09320010LF
Driver Name: emlxs
Driver Version: 2.50o (2010.01.08.09.45)
Type: unknown
State: offline
Supported Speeds: 1Gb 2Gb 4Gb
Current Speed: not established
Node WWN: 20000000c98e6a99
HBA Port WWN: 10000000c98e6a86
OS Device Name: /dev/cfg/c2
Manufacturer: Emulex
Model: LPe11000-S
Firmware Version: 2.82a4 (Z3D2.82A4)
FCode/BIOS Version: Boot:5.02a1 Fcode:1.50a9
Serial Number: 0999VM0-09320010LK
Driver Name: emlxs
Driver Version: 2.50o (2010.01.08.09.45)
Type: unknown
State: offline
Supported Speeds: 1Gb 2Gb 4Gb
Current Speed: not established
Node WWN: 20000000c98e6a86
No Network Array enclosures found in /dev/es
Logical Path:/dev/rdsk/c5t50060E800475D109d6s2
Node WWN:50070e800475e108 Device Type:Disk device
Logical Path:/dev/rdsk/c5t50060E800475D109d7s2
HBA card WWN
# prtconf -vp | grep wwn
port-wwn: 2100001b.3202f94b
node-wwn: 2000001b.3202f94b
port-wwn: 210000e0.8b90e795
node-wwn: 200000e0.8b90e795
#prtconf -vp | more
For Solaris 8 and 9:
Run the following script to determine the WWNs of the HBAs that are currently being utilized:
#!/bin/sh for i in `cfgadm |grep fc-fabric|awk ‘{print $1}’`;
do
dev=”`cfgadm -lv $i|grep devices |awk ‘{print $NF}’`” wwn= \
“`luxadm -e dump_map $dev |grep ‘Host Bus’|awk ‘{print $4}’`”
echo “$i: $wwn” done
To show link status of card
bash-2.03# luxadm -e port
Found path to 2 HBA ports
/devices/ssm@0,0/pci@18,700000/SUNW,qlc@2/fp@0,0:devctl CONNECTED
/devices/ssm@0,0/pci@19,700000/SUNW,qlc@2/fp@0,0:devctl CONNECTED
To see the WWN’s (using address given to you from previous commands),
it is the last one that specifies it is a HBA, so the port WWN here is 50070e800475e108
bash-2.03# luxadm -e dump_map /devices/ssm@0,0/pci@18,700000/SUNW,qlc@2/fp@0,0:devctl
Pos Port_ID Hard_Addr Port WWN Node WWN Type
0 642113 0 50070e800475e108 50070e800475e108 0×0 (Disk device)
1 643f13 0 550070e800475e108 50070e800475e108 0×0 (Disk device)
2 643913 0 2100001b3205e828 2000001b3205e828 0x1f (Unknown Type,Host Bus Adapter)
SAN Foundation Software versions display as such
bash-2.03# modinfo | grep SunFC
38 102bcd25 209b8 150 1 fcp (SunFC FCP v20070703-1.98)
39 102d4071 855c - 1 fctl (SunFC Transport v20070703-1.41)
42 102ead69 164e0 149 1 fp (SunFC Port v20070703-1.60)
44 10300a79 cd574 153 1 qlc (SunFC Qlogic FCA v20070212-2.19)
To show Sun/Qlogic HBA’s
bash-2.03# luxadm qlgc
Found Path to 2 FC100/P, ISP2200, ISP23xx Devices
Opening Device: /devices/ssm@0,0/pci@18,700000/SUNW,qlc@2/fp@0,0:devctl
Detected FCode Version: ISP2312 Host Adapter fcode version 1.16 11/15/06
Complete
To show all vendor HBA’s
bash-2.03# luxadm fcode_download -p
Found Path to 0 FC/S Cards
Complete
Found Path to 0 FC100/S Cards
Complete
Found Path to 2 FC100/P, ISP2200, ISP23xx Devices
Opening Device: /devices/ssm@0,0/pci@18,700000/SUNW,qlc@2/fp@0,0:devctl
Detected FCode Version: ISP2312 Host Adapter fcode version 1.16 11/15/06
Opening Device: /devices/ssm@0,0/pci@19,700000/SUNW,qlc@2/fp@0,0:devctl
Detected FCode Version: ISP2312 Host Adapter fcode version 1.16 11/15/06
Complete
Found Path to 0 JNI1560 Devices.
Complete
Found Path to 0 Emulex Devices.
Complete
#fcinfo hba-port
HBA Port WWN: 10000000c98e6a99
OS Device Name: /dev/cfg/c1
Manufacturer: Emulex
Model: LPe11000-S
Firmware Version: 2.82a4 (Z3D2.82A4)
FCode/BIOS Version: Boot:5.02a1 Fcode:1.50a9
Serial Number: 0999VM0-09320010LF
Driver Name: emlxs
Driver Version: 2.50o (2010.01.08.09.45)
Type: unknown
State: offline
Supported Speeds: 1Gb 2Gb 4Gb
Current Speed: not established
Node WWN: 20000000c98e6a99
HBA Port WWN: 10000000c98e6a86
OS Device Name: /dev/cfg/c2
Manufacturer: Emulex
Model: LPe11000-S
Firmware Version: 2.82a4 (Z3D2.82A4)
FCode/BIOS Version: Boot:5.02a1 Fcode:1.50a9
Serial Number: 0999VM0-09320010LK
Driver Name: emlxs
Driver Version: 2.50o (2010.01.08.09.45)
Type: unknown
State: offline
Supported Speeds: 1Gb 2Gb 4Gb
Current Speed: not established
Node WWN: 20000000c98e6a86
Posted In HBA | 0 comments |
Subscribe to:
Posts (Atom)